Last week Centreon 2.5 and centreon broker have been launched. After testing the beta it was time for me to migrate.

On this post I’ll give you some tips to make your migration easier.

First I recommend you to follow the instructions in the release note on centreon documentation.

At this step you have upgraded your central server but what about your pollers ?

We’ll see this point on the next part.

Poller update

Which packages need to be update or installed to complete your migration ?

If you are using centreon broker, you should update the broker modules on pollers. NDO users you could skip this step.

In the 2.5 release, Centreon introduced a new system for SNMP traps, so you need to install it on your pollers and on your central.

Centreon traps require the installation of centreon-perl-libs, new useful perl libraries for Centreon.

If you a re using Centreon Enterprise Server these packages come with the upgrade ofcentreon 2.5.

It’s strongly recommended to update you centreon plugins on your pollers. In this way you will have the same versions on your central and on your pollers.

It’s over ? No we go back on your central server.

Central server

In this new release of Centreon, centcore has changed. Indeed this centreon process is now using centreon perl libraries. After the update of the central, you didn’t restart centcore and it is not running with the new version.

That’s why I recommend you to restart centcore process and push your configuration on your pollers to verify if everything is ok.

Why did I put this step at the end of my article ? It’s just to force you to make the update on your pollers.

comments powered by Disqus